In previous articles we configured IS-IS and LDP between all the core devices, and create two VRF/Routing-Instances in the PEs. In this article we are going to start with the BGP configuration.
The IOS-XR device is
going to be VPNv4 BGP Route Reflector, and we are going to have one BGP session
against the Cisco IOS PE and Junos PE.
XR:
router bgp 100
bgp router-id 1.1.1.1
address-family vpnv4 unicast
neighbor 4.4.4.4
remote-as 100
update-source Loopback0
address-family vpnv4 unicast
route-reflector-client
neighbor 5.5.5.5
remote-as 100
update-source Loopback0
address-family vpnv4 unicast
route-reflector-client
CiPE:
router bgp 100
bgp router-id 4.4.4.4
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
JPE:
set protocols bgp group RR type internal
set protocols bgp group RR local-address 5.5.5.5
set protocols bgp group RR family inet-vpn unicast
set protocols bgp group RR neighbor 1.1.1.1
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 100
After the VPNv4
configuration the BGP session will be up, but no prefixes will be received at
any peer.
XR:
RP/0/0/CPU0:XR#sh bgp vpnv4 unicast summary
Wed Jun 22 04:41:20.730 UTC
BGP router identifier 1.1.1.1, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 1
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs
BGP is operating in STANDALONE mode.
Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 1 1 1 1 1 0
Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 100 15 13 1 0 0 00:10:28 0
5.5.5.5 0 100 20 18 1 0 0 00:07:36 0
CiPE:
CiPE#show bgp vpnv4 unicast all summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 8 9 1 0 0 00:05:12 0
JPE:
lab@JPE> show bgp summary
Groups: 1 Peers: 1 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0
0 0 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
1.1.1.1 100 3 6 0 0 1:28 Establ
bgp.l3vpn.0: 0/0/0/0
Advertising the local VRF interfaces:
Now start
advertising the local interface of each vrf to the BGP. For junos there are not
redistribution or network statement commands, all prefixes need to be announced
using a route policy.
CiPE:
router bgp 100
address-family ipv4 vrf EVEN
network 192.168.1.0
exit-address-family
address-family ipv4 vrf ODD
network 172.16.1.0 mask 255.255.255.0
exit-address-family
JPE:
set policy-options policy-statement Export_EVEN term 2 from interface ge-0/0/6.0
set policy-options policy-statement Export_EVEN term 2 then community add rt_222:222
set policy-options policy-statement Export_EVEN term 2 then accept
set policy-options policy-statement Export_ODD term 2 from interface ge-0/0/5.0
set policy-options policy-statement Export_ODD term 2 then community add rt_111:111
set policy-options policy-statement Export_ODD term 2 then accept
set routing-instances ODD vrf-table-label
set routing-instances EVEN vrf-table-label
By default Juniper
devices has this behaviour: BGP will not advertise the directly connected
network to the remote PE router in L3VPN without vrf-table-label or some other
route to advertise.
set
routing-instances <Routing_instance> vrf-table-label allow to generate a
label for this prefixes.
Now we should be able to ping the remote interfaces in the same routing table, and we should be learning prefixes using VPNv4 MP-BGP. Your basic MPLS network is already working.
CiPE:
CiPE#show bgp vpnv4 unicast all summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 17, main routing table version 17
4 network entries using 624 bytes of memory
4 path entries using 320 bytes of memory
4/4 BGP path/bestpath attribute entries using 640 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
2 BGP extended community entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1656 total bytes of memory
BGP activity 5/1 prefixes, 5/1 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 37 40 17 0 0 00:30:15 2
CiPE#show ip route vrf ODD
Routing Table: ODD
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.1.0/24 is directly connected, Ethernet0/1
L 172.16.1.1/32 is directly connected, Ethernet0/1
B 172.16.2.0/24 [200/0] via 5.5.5.5, 00:19:25
CiPE#show ip route vrf EVEN
Routing Table: EVEN
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Ethernet0/0
L 192.168.1.1/32 is directly connected, Ethernet0/0
B 192.168.2.0/24 [200/0] via 5.5.5.5, 00:21:03
CiPE#
CiPE#ping vrf EVEN 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/5/13 ms
JPE:
lab@JPE> show route table ODD
ODD.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
172.16.1.0/24 *[BGP/170] 00:28:06, MED 0, localpref 100, from 1.1.1.1
AS path: I, validation-state: unverified
> to 10.0.4.1 via ge-0/0/7.0, Push 25, Push 20(top)
172.16.2.0/24 *[Direct/0] 03:02:29
> via ge-0/0/5.0
172.16.2.1/32 *[Local/0] 03:02:29
Local via ge-0/0/5.0
lab@JPE> show route table EVEN.inet.0
EVEN.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
192.168.1.0/24 *[BGP/170] 00:28:10, MED 0, localpref 100, from 1.1.1.1
AS path: I, validation-state: unverified
> to 10.0.4.1 via ge-0/0/7.0, Push 22, Push 20(top)
192.168.2.0/24 *[Direct/0] 03:02:33
> via ge-0/0/6.0
192.168.2.1/32 *[Local/0] 03:02:33
Local via ge-0/0/6.0
lab@JPE> show bgp summary
Groups: 1 Peers: 1 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0
2 2 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
1.1.1.1 100 65 72 0 6 29:04 Establ
bgp.l3vpn.0: 2/2/2/0
ODD.inet.0: 1/1/1/0
EVEN.inet.0: 1/1/1/0
XR:
RP/0/0/CPU0:XR#show bgp vpnv4 unicast summary
Wed Jun 22 05:54:20.000 UTC
BGP router identifier 1.1.1.1, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 14
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs
BGP is operating in STANDALONE mode.
Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 14 14 14 14 14 0
Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 100 109 101 14 0 0 00:28:16 2
5.5.5.5 0 100 221 191 14 0 0 00:27:38 2
There are
reachability between the PEs in the VRFs, next step is to configure PE-CE
routing protocols.